Originally published here by Kirk Bixler, May 3, 2018.

Problem: APM UI Expiring Certificates ─ During the upgrade processing from APM 8.1.3 to APM 8.1.4, the 8.1.3 APMUI certificate keystore and truststore files are copied to a new 8.1.4 location where they are shared by the APMUI, Server1, OIDC, and UViews servers. The default certificate contained in these files is set to expire on April 21, 2019.

Symptom: When the certificate expires, users will receive a “Secure Connection Failed” message in their browser instead of the APM Login Page.

Solution: In order to maintain valid UI certificates in those upgraded APM 8.1.4 installations still using the default out of the box certificates, the existing keystore and truststore files must be replaced using the ones provided with this technote. These new keystores contain certificates that are set to expire in March of 2028.

Continue reading here.

Join The Discussion

Your email address will not be published. Required fields are marked *