CICS Transaction Gateway V9.2 Fix pack 2 is available now for both Multiplatforms and Desktop Edition products. This fix pack is available at Fix Central , and also as a refreshed eGA image through Passport Advantage.

  1. With V9.2.0.2, CICS TG supports Windows server 2016 and Microsoft Visual Studio 2017.
  2. Support for .NET Core APIs has been provided through V9.2 SDK. See this link for more details.

Refer CICS TG V9.2 Knowledge Center for more details.

Other useful links:
1. Current Maintenance Levels for CICS Transaction Gateway for Multiplatforms and CICS Transaction Gateway Desktop Edition Products

2. Details about Fix Central link: CICS Transaction Gateway Desktop Edition V9.2 Fix Pack 2

3. Details on Part numbers for Desktop Edition: CICS Transaction Gateway Desktop Edition V9.2 (all supported platforms)

4. Details about Fix Central link: CICS Transaction Gateway for Multiplatforms V9.2 Fix Pack 2

5. Details on Part numbers for Multiplatforms: CICS Transaction Gateway for Multiplatforms V9.2 (all supported platforms)

6. List of APARs in V9.2.0.2: CICS Transaction Gateway V9.2 Maintenance

5 comments on"CICS TG V9.2 Fix pack 2 available now – with support for Win 2016 !!"

  1. David E Jones March 23, 2018

    Hello, We run CICS TG for z/OS (v9.2.0.0) — and have some .NET clients running on Windows Server Enterprise (currently 2008)..
    We’ve been waiting for CICS TG support its .NET API, on Windows Server 2016..

    Can you confirm .. We can use the 9.2.0.2 assembly (IBM.CTG.Client.dll) on Windows Server 2016 to connect the CICS TG z/OS 9.2.0.0..

    Thank you,Dave

    • Hi Dave,

      Thanks for your interest.

      Yes, you can use the 9.2.0.2 assembly for .NET framework IBM.CTG.Client.dll on Windows 2016 to connect to CICS TG z/OS V9.2. Additionally, CICS TG now supports .NET Core as well through IBM.CTG.Core.dll, provided in the same SDK.

      Please let us know for any further questions / feedback.

      Thanks,
      Janaki.

  2. David E Jones March 23, 2018

    Thank you — One additional question .. We deployed the 9.2.0.2 dll when it was first made available — The assembly is dated 1/17/2018 — the assembly included in the latest SDK is dated 3/11/2018 —
    Their lengths match – but can you confirm this is the same code ..

    Thanks, Dave

    • The V9.2.0.2 SDK is refreshed as part of the usual Fix pack practice and as there could be potential APAR fixes required for SDK deliverables. With respect to .NET framework or .NET Core, it’s recommended to download the latest SDK, as it would have fixes from continuous testing and therefore improved quality.

Join The Discussion

Your email address will not be published. Required fields are marked *