When installing IBM Explorer for z/OS or IBM CICS Explorer with p2 on an existing Eclipse platform, you may encounter this error pertaining to an RSE version conflict:

Cannot complete the install because of a conflicting dependency.

Software being installed: IBM Explorer for z/OS 3.1.104.201801101417 (com.ibm.zeus.feature.feature.group 3.1.104.201801101417)

Software currently installed: Remote System Explorer End-User Runtime 3.7.3.201704251225 (org.eclipse.rse.feature.group 3.7.3.201704251225)

    Only one of the following can be installed at once:
  • Remote System Explorer End-User Runtime 3.7.3.201704251225 (org.eclipse.rse.feature.jar 3.7.3.201704251225)
  • Remote System Explorer End-User Runtime 4.6.6.201801100355 (org.eclipse.rse.feature.jar 4.6.6.201801100355)

This is caused by a conflicting RSE (Remote System Explorer) dependency where the open-source version (RSE 3.7) has been preinstalled as a part of the existing Eclipse package (typically through Eclipse for Java EE), which is incompatible with the version used in the current IBM offering.

To resolve this issue, check "Show original error and build my own solution" and "Remove items already installed" when this window is presented:

RSE conflict window

Proceed with the install with those options checked and the previous version of RSE will be uninstalled prior to the IBM offering installation which will prevent the conflict from occurring again.

Join The Discussion

Your email address will not be published. Required fields are marked *