We’ve just released V3.0.25 of z/OS Connect EE.

In this release we have added two new features for users of API requester:

  • JSON Web Token (JWT) support.
  • Greater than 32K length JSON string fields support.

We have also

JWT support for API requesters

z/OS Connect EE API requester JWT support can now be used when a CICS, IMS, or z/OS application calls a RESTful API that requires a JWT. On behalf of the CICS, IMS or z/OS application, z/OS Connect EE acts as a client to request a JWT from an authentication server and access the API with the JWT.
Find out more.

Greater than 32K length JSON string fields now supported for API requester

For API requester, support for greater than 32K length JSON string fields is now available. Two new build toolkit properties, characterVarying and characterVaryingLimit, control how variable-length character data is mapped to a language structure. Together with defaultCharacterMaxLength, these properties allow strings with a maximum length of 16,777,214 bytes to be mapped as fixed-length strings, null-terminated strings, or as two related elements: data-length and data.
Find out more.

Upgrading from a previous release of z/OS Connect EE

After upgrading to z/OS Connect EE V3.0.25, the first time you start up your server, you must specify the
--clean option on your started task PARMS statement, for example: /S BAQSTRT,PARMS=' serverName --clean'. This is to delete all persistent cached information and pick up updated OSGi bundles shipped in this release.
Find out more about the –clean option.

If you fail to specify the –clean option your server may not function correctly and you may see the following errors in your messages.log, STDERR, and FFDC:


[ERROR   ] CWWKF0002E: A bundle could not be found for com.fasterxml.jackson.core.jackson-annotations/2.9.x.          
[ERROR   ] CWWKF0002E: A bundle could not be found for com.fasterxml.jackson.core.jackson-databind/2.9.x.             
[ERROR   ] CWWKF0002E: A bundle could not be found for org.apache.commons.commons-compress/1.18.0.                    
[ERROR   ] CWWKF0002E: A bundle could not be found for com.fasterxml.jackson.dataformat.jackson-dataformat-yaml/2.9.x.
[ERROR   ] CWWKF0002E: A bundle could not be found for com.fasterxml.jackson.core.jackson-core/2.9.x.

Subsequent starts of the server do not require the --clean option.

WebSphere Liberty Profile 19.0.0.6

The version of WebSphere Liberty Profile that is embedded in z/OS Connect EE V3.0.25 is V19.0.0.6.

Angel V11

The version of the angel shipped with WebSphere Liberty Profile V19.0.0.6 is version 11. This is the same version that was shipped with Liberty V19.0.0.3.

You are advised to update your system so that your z/OS Connect EE server uses this version of the angel. If you choose not to update to this level of the angel, then the following warning message will appear in your messages.log file:


CWWKB0127W: The current angel version is earlier than the version that the server expects. Update the angel version to the latest available version.

Find out more.

API toolkit versions

The latest version of the z/OS Connect EE API toolkit plug-in to design and create your services and APIs is V3.0.6.9 for Aqua 3.1 users, and V3.2.6.9 for Aqua 3.2 users. You are recommended to use the latest version of the API toolkit for your version of Aqua as it includes all the latest features and fixes.
Find out more.

Get started today

Use the links below to find out more, and to get started with V3.0.25 now!


New to z/OS Connect EE?

What’s in this release?

Download V3.0.25 Now

Join The Discussion

Your email address will not be published. Required fields are marked *