We’ve just released V3.0.26 of z/OS Connect EE.

In this release we have made the following updates:

Support for Boolean fields in Services

The z/OS Connect EE API toolkit has been enhanced with the capability to expose service fields in JSON payloads as a Boolean data type. By defining specific request and response conditions to process true or false values for a given service field, the definition of the underlying COBOL or PL/I application field remains unchanged.

To use this feature you require the API toolkit to be V3.0.6.10 for Aqua 3.1 users, and V3.2.6.10 for Aqua 3.2 users, and the runtime to be 3.0.26 or later.
Find out more.

Java 8 required to run z/OS Connect EE

Java 8 is the only supported level of Java to run z/OS Connect EE V3.0.26. Your z/OS Connect EE server will not start if Java 8 is not used. It will fail with return code 256, and a message “Error: zosconnect can not run server 'your server' does not exist”.
Find out more.

WebSphere Liberty Profile 19.0.0.9

The version of WebSphere Liberty Profile that is embedded in z/OS Connect EE V3.0.26 is V19.0.0.9.

Angel V12

The version of the angel shipped with WebSphere Liberty Profile V19.0.0.9 is version 12.

You are advised to update your system so that your z/OS Connect EE server uses this version of the angel. If you choose not to update to this level of the angel, then the following warning message will appear in your messages.log file:


CWWKB0127W: The current angel version is earlier than the version that the server expects. Update the angel version to the latest available version.

Find out more.

API toolkit versions

The latest version of the z/OS Connect EE API toolkit plug-in to design and create your services and APIs is V3.0.6.10 for Aqua 3.1 users, and V3.2.6.10 for Aqua 3.2 users. You are recommended to use the latest version of the API toolkit for your version of Aqua as it includes all the latest features and fixes, including the new boolean support.
Find out more.

Get started today

Use the links below to find out more, and to get started with V3.0.26 now!


New to z/OS Connect EE?

What’s in this release?

Download V3.0.26 Now

Join The Discussion

Your email address will not be published. Required fields are marked *