page-brochureware.php

IBM SDK for Node.js Version 8


IBM SDK for Node.js Version 8

The IBM® SDK for Node.js Version 8 is equivalent to the community Node.js API version 8.1.4.

Note: The community Node.js version on which this release is based is not scheduled to enter long-term support (LTS) until October 2017. Until then, it is recommended that you use this release only for development purposes, as the expected rate of change and risk of regressions is higher than in LTS releases. If you need support or are deploying to production, it is recommended that you use the current LTS release, 6.x, instead.


Downloads


Note: Read and follow the instructions in the Late breaking information before trying to download and install the macOS package. The macOS operating system has an ‘Allow apps downloaded from’ setting that might prevent you from successfully installing the downloaded package.

Supported Environments


Hardware: The minimum supported hardware levels for PowerPC® and z Systems are POWER7® and zEnterprise® 196 respectively.

Software: The following table shows the operating systems that are supported for each platform architecture for the IBM SDK for Node.js version 8. Only 64-bit operating systems are supported.

Note: The SDK is supported only on operating system levels that are themselves still officially supported by their maintainers.

x86-64 IBM 64-bit Power Systems IBM 64-bit z Systems (3)
AIX 7.1 TL4 or later Yes (1)
RHEL 7.3 or later Yes Yes (2) Yes
SLES 12 Yes Yes
Ubuntu 14.04 LTS Yes Yes (2)
Ubuntu 16.04 LTS Yes Yes (2) Yes
Windows 7 or 10 Yes (4)
Windows Server 2012 or 2016 Yes
macOS 10.12 or later Yes
Notes:

1: Available only in Big Endian architecture format.

2: Available only in Little Endian architecture format for use on POWER hardware systems.

3: Including IBM LinuxONE.

4: Although unsupported, the SDK should run on Windows 8.