The end of Java 6 support is coming!

Oracle has announced Extended Support for Java 6 will end December 2018. What does this mean for your WebSphere installation?

Summary

On April 30, 2018, WAS 8.5.x will no longer support Java 6 as its runtime. WAS 8.5.5.13 will be the last fix pack to support Java 6 and, starting with WAS 8.5.5.14, the embedded Java 6 will be removed and replaced with Java 8.

Details of Java 6 end of support

WAS v8.5 supports pluggable JDK which means you can use WAS v8.5 with Java 6, 7, or 8. With the Java 6 end of support (EoS) coming, IBM strongly encourages customers to move to Java 7 or 8. Migration to a newer version of Java will help customers move away from aging crypto technologies and avoid the risks of non-addressed future security exposures. Also, with the pluggable JDK support of WAS v8.5, switching JDKs is fairly easy.

For customers on WAS 8.5.x, IBM announced that Java 6 will no longer be a supported WebSphere runtime after April 30, 2018. WAS 8.5.5.13, currently scheduled for February 2018, will be the last fix pack to support Java 6. Starting in WAS 8.5.5.14, the embedded installation of Java 6 will be removed and replaced with Java 8. If you wish to remove Java 6 before 8.5.5.14, you will need to perform a new installation of WebSphere. Otherwise, Java 6 will be removed with an in-place upgrade with fix pack 8.5.5.14.

After April 30, 2018, fixes to the Java 6 runtime will be limited. Customers will be able to get security fixes from IBM, which include the Oracle Critical Patch Updates (CPUs) for Java 6, until December 2018. Only CPU fixes will be available after April 30, 2018.

For Liberty users: Liberty ceased support of Java 6 in version 17.0.0.3. To use the latest version of Liberty you must upgrade to Java 7 or Java 8.

Updated 2018-03-14: After April 30, 2018, security fixes for the IBM SDKs will be available from IBM, not Oracle as previously implied.

4 comments on"Java 6 end of support: What does this mean to WAS v8.5 customers?"

  1. we are currently updating the webserver from some version of WAS to WLP 17.
    When deploying to WLP 17, we get the following error message:
    java.lang.NoClassDefFoundError: osplus.dms.spring.SpringApplicationContextHolder (initialization failure); nested exception is:
    java.lang.NoClassDefFoundError: osplus.dms.spring.SpringApplicationContextHolder (initialization failure)
    Is for some reason WLP 17 not compatible to Spring 3.2.1?

    • Hi, I’ve been asking around. We’re not aware of any specific issue with Spring 3.2.1 and Liberty.

      From your brief description, it sounds like it might be an app packaging or deployment issue. The exception suggests it can’t load the classes. It doesn’t seem to be related to it being Liberty 17.0.0.x.

      It might be worth also posting your question with as much detail as you can on Stack Overflow (http://stackoverflow.com/questions/ask/?tags=websphere-liberty). Someone with a similar experience might then be able to help. The additional details will also help determine the cause.

      Thanks

  2. And what happend if i have 8.0.0.6

    • alasdair@rtp November 13, 2017

      WebSphere Application Server v8 reaches end of support 30th April 2018. You should be planning a migration to WAS 8.5.5, or 9.0.0 at this time.

Join The Discussion

Your email address will not be published. Required fields are marked *