Logstash is phasing out the Lumberjack input plugin and no longer includes it in its default bundle starting in version 6.0. They now recommend you use the Beats input plugin.

If you are using the logstashCollector-1.0 or logstashCollector-1.1 features in WebSphere Liberty, you can switch the input plugin from Lumberjack to Beats in the Logstash configuration file. The logstashCollector-1.0 and logstashCollector-1.1 features work with both Lumberjack and Beats input plugins. No special configuration is required for logstashCollector in server.xml.

The sample Logstash configuration files provided in Github have been updated:

Join The Discussion

Your email address will not be published. Required fields are marked *